Overview
This article provides guidance on resolving a common error message that appears when attempting to tick the actual for a date where an employee has a Time and Attendance (T&A) record but subsequently has an overlapping entry, such as an absence or holiday
Error Message
When trying to tick the actual, the error 'T&A actions must be completed before day can be set to Actual' is displayed (see Fig.1).
In the T&A page, the following status will show on the record: 'Existing absence must be deleted before creating shift' (see Fig.2).
Cause
This issue is caused by the organisation setting Prevent Actual Sign Off if T&A Actions Outstanding, which prevents the day from being completed when T&A records have not been actioned.
be able to set the day to actual."
This setting is designed to make sure all T&A records are reviewed and actioned before the day is closed to ensure no records are missed.
However, there are situations where it causes a conflict. Example senorios:
The employee clocks in and then goes home sick, and an absence record is added to cover the remainder of the day
Employee forgets they are on holiday and clocks in
Employee is on SMP leave and clocks in on a KIT day
Due to the record taking up the day, the T&A record can't be actioned, leading to a conflict.
Resolution
To make sure the absence (or other record) remains booked, we recommend the following steps:
Ask your administrator to untick the organisation setting Prevent Actual Sign Off if T&A Actions Outstanding by following the path Scheduling > Settings > Manage Organisation
Go to the site and tick the actual for the day
Once complete, the administrator can reapply the setting.
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